Tijdens het updaten van Kali Linux werd ik vandaag geconfronteerd met een GPG error. Na enig speurwerk heb ik hier een werkende oplossing voor kunnen vinden. Het updaten van Kali Linux werkt hierna weer zoals bedoeld.

JPortal.nl-Blog-Update-Kali-Linux-GPG-error-1

Voor het updaten en upgraden van Kali Linux gebruik ik het onderstaande commando:

apt update && apt full-upgrade

Tijdens de update proces kreeg ik de bovenstaande error te zien. Deze maakt melding van invalid signatures. De eerst stap was het controleren van de sources.list

cat /etc/apt/sources.list

Hier stonden nog enkele oude sources in. Om er zeker van te zijn dat dit geen problemen oplevert, heb ik alles verwijderd op de onderstaande sources na.

vi /etc/apt/sources.list
# druk op i en schoon de hele lijst op
# voeg de onderstaande sources toe
deb http://http.kali.org/kali kali-rolling main non-free contrib
deb-src http://http.kali.org/kali kali-rolling main non-free contrib
# druk op escape
# sla de wijzigingen op met :wq

Een nieuw poging leverde nog steeds dezelfde GPG error op. Hierna heb ik de oude keys verwijderd en kali-archive-keyring geïnstalleerd.

rm -rf /var/lib/apt/lists
apt-get update 
apt-get install kali-archive-keyring

JPortal.nl-Blog-Update-Kali-Linux-GPG-error-2

Hierna opnieuw het update en upgrade proces gestart en dit maal zonder problemen alles kunnen updaten en upgraden

Geef een reactie

Het e-mailadres wordt niet gepubliceerd. Vereiste velden zijn gemarkeerd met *